[gradsusr] Grads 2.2.0 gxprint libpng error

Marco Biordi - PODOS3D marcobiordi at podos3d.sm
Thu Mar 15 11:46:09 EDT 2018

Hello users,

when I run grads and make an hardcopy with the command gxprint I get an empty 
PNG image and GrADS return the following error

libpng warning: Image width exceeds user limit in IHDR
libpng warning: Image height exceeds user limit in IHDR
gd-png:  fatal libpng error: Invalid IHDR data

I run GrADS 2.2.0, pre-built grads-2.2.0-bin-rhel6.4-x86_64.tar.gz.

My system (Centos-6.5-x86_64) is still on libpng-1.2.49; when I run grads, it 
fails with error "GX Package Error: dlopen failed to get a handle on gxprint 
plug-in named "Cairo", "libpng15.so.15: cannot open shared object file: No such 
file or directory".

So I have build myself libpng-1.15.12 and all commands except gxprint now seem 
to work.

Before to run grads I do commands:

 > setenv LD_LIBRARY_PATH /usr/util/grads/libpng-1.5.12/lib

 > setenv GADDIR /usr/util/grads/data

 > setenv GAUDPT /usr/util/grads/udpt [ maybe redundant ]

File udpt contains these lines:

# Type     Name     Full path to shared object file
# ----     ----     -------------------------------
gxdisplay  Cairo    /usr/util/grads/lib/libgxdCairo.so
gxdisplay  X11      /usr/util/grads/lib/libgxdX11.so
gxdisplay  gxdummy  /usr/util/grads/lib/libgxdummy.so
gxprint    Cairo    /usr/util/grads/lib/libgxpCairo.so
gxprint    GD       /usr/util/grads/lib/libgxpGD.so
gxprint    gxdummy  /usr/util/grads/lib/libgxdummy.so

Folder /usr/util/grads/lib contains these files:


Please can anybody help?

Thanks in advance


More information about the gradsusr mailing list