grads-2.0.a1 segmentation fault

Arlindo da Silva dasilva at ALUM.MIT.EDU
Thu May 1 21:19:25 EDT 2008

On Thu, May 1, 2008 at 3:05 PM, Matt Alonso <matt.alonso at> wrote:

> Hi Arlindo,
> Thank you for taking a look at this.  As a reference I attached the script
> I am using to output the ASCII data.  I can contour/shade the data fine
> (animation works for me as well).  The issue comes in when writing the ASCII
> CSV file.  I spent all of a couple minutes tweaking the code so there could
> definitely be something wrong in there but nothing stands out in my mind.
> The box this is on runs Fedora Core 5 (it is ancient I know) and has 2
> dual 3.0GHz Intel xeon cpus and 2GB of RAM.  Nothing seemed out of place
> with the memory usage when I was running the process.
> Let me know if I missed anything.

Hmm. I tried your script on my Mac OS X with v1.9.0-rc1 and it worked just
fine. I need to know exactly  which version and build date you are having
problems with.

Out of curiosity I modified a PyGrADS script I posted the other day to print
a CSV file for one of your files, see attached. The script is a bit shorter
than your original gs script and ran much faster on my Mac. If you cannot
get GrADS to work with your script this could be an alternative to produce
your CSV files.

 BTW, what is the application of these CSV files? Is it for excel?


Arlindo da Silva
dasilva at
-------------- next part --------------
An HTML attachment was scrubbed...
-------------- next part --------------
A non-text attachment was scrubbed...
Type: text/x-python-script
Size: 1211 bytes
Desc: not available
Url : 

More information about the gradsusr mailing list