grads-2.0.a1 segmentation fault

Matt Alonso matt.alonso at GMAIL.COM
Thu May 1 10:37:39 EDT 2008

Was anyone ever able to find a solution to this issue?  I think I am
experiencing a similar problem using gradsnc v1.9b4.  I have a 13MB netCDF
file (samples can be found here,
which contains Reanalysis rainfall rate data.

My script - based off of a script I found in the list archives - attempts to
loop over all points in the file for all timesteps (366) and at each point
(192x94) it will write ASCII output to a file.  If I run it for less than 4
timesteps it works like a charm but if I set it to use 4 or more timesteps
it will always fail on the 4th one at point 161,69 running the command to
display the value.  My first instinct was that the data at that particular
point/time was somehow corrupted but subsequent tests showed that it doesn't
matter what timestep I start at it will always fail the 4th time through at
that exact X,Y.

Anyone have any ideas about what the issue might be?  Thanks in advance.


On Tue, Apr 1, 2008 at 3:02 AM, Steven Weiss <sweiss at> wrote:

>  Hi Jennifer,
> The problem is now occurring inconsistently in both batch mode and from
> command line.
> I've tried using top to examine the memory and there is no issue here.
> I've also cleared cache memory i.e. "echo 1 > drop_caches"
> I've also tried rebooting and this has made no difference either.
> I've managed to get the following below through gdb and also have a core
> which I generated through gdb (21mb).
> Any suggestions moving forward?
> Regards
> Steven
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the gradsusr mailing list