[gradsusr] [EXTERNAL] Problems by opening grads on Mac OS Big Sur

Adams, Jennifer M. (GSFC-610.2)[ADNET SYSTEMS INC] jennifer.m.adams at nasa.gov
Thu May 20 13:47:53 EDT 2021

Hi, Moritz –
Sorry for the very long delay. How the dynamic linker works on Mac is a bit of a mystery to me, and it makes new grads builds much less portable. I have no idea why your build is looking for a file in my home directory. Did you copy the supplibs from ftp://cola.gmu.edu/grads/Supplibs/2.2/builds/ ?

My first suggestion is to use macports to install grads. If that is not an option, try to use the environment variable LD_LIBRARY_PATH to point to locations where you want the linker to look for specific libraries. If you have libpng15.15.dylib  on your system, add the path to LD_LIBRARY_PATH. The command:
    > otool -L <executable or library name>
will show you where the linker found the required dynamically linked libraries. Next version will just ask for libpng, not libpng15 and that may simplify things, since the current version is now libpng16.

If you really want to dig for it, libtool will install ascii file (it has a .la extension) along with the library that contains information helpful to the dynamic linker (library name aliases, version information, other dependent libs, etc.) That file gets a hard-coded path that you can change if it doesn’t match what’s on your system. I have used that as a workaround in the past.

Good luck! I’ll be upgrading to Big Sur myself this week and will have to rebuild my GrADS environment from scratch…

Jennifer Miletta Adams
ADNET Systems, Inc.
NASA/GSFC, Code 610.2
Building 32, Room S159
(301) 614-6070

From: gradsusr <gradsusr-bounces at gradsusr.org> on behalf of "Moritz Haupt (Web)" <Moritzhaupt at web.de>
Reply-To: GrADS Users Forum <gradsusr at gradsusr.org>
Date: Tuesday, May 4, 2021 at 7:49 AM
To: "gradsusr at gradsusr.org" <gradsusr at gradsusr.org>
Subject: [EXTERNAL] [gradsusr] Problems by opening grads on Mac OS Big Sur


I’m trying to run grads on my Mac OS Big Sur but always when I write grads to open it this problem comes up:

dyld: Library not loaded: /Users/jma/grads/supplibs/lib/libpng15.15.dylib
  Referenced from: /usr/local/bin/grads
  Reason: image not found
zsh: abort      grads

I’m facing this problems for a view days and can’t find a solution, I tried a lot but nothing worked.
I do have the newest versions of homebrew, grads etc.
Maybe you can help me!

Thank you in advance!
Kind regards,
Moritz Haupt
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://gradsusr.org/pipermail/gradsusr/attachments/20210520/82fb1b1c/attachment.html>

More information about the gradsusr mailing list